运行Junit方法项目启动不了

 

从控制台看不出任何有用信息,通过JUnit右键”Copy Failure List”将信息拷贝出来

 

TestStart.start

initializationError(org.junit.runner.manipulation.Filter)

java.lang.Exception: No tests found matching [{ExactMatcher:fDisplayName=start], {ExactMatcher:fDisplayName=start(TestStart)], {LeadingIdentifierMatcher:fClassName=TestStart,fLeadingIdentifier=start]] from org.junit.internal.requests.ClassRequest@47f6473

at org.junit.internal.requests.FilterRequest.getRunner(FilterRequest.java:40)

at org.eclipse.jdt.internal.junit4.runner.JUnit4TestLoader.createFilteredTest(JUnit4TestLoader.java:77)

at org.eclipse.jdt.internal.junit4.runner.JUnit4TestLoader.createTest(JUnit4TestLoader.java:68)

at org.eclipse.jdt.internal.junit4.runner.JUnit4TestLoader.loadTests(JUnit4TestLoader.java:43)

at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:444)

at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:675)

at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:382)

at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:192)

 这种Junit启动不了无非几种情形:

  1. 测试方法上没有添加@Test注解
  2. 测试类名称是有歧义的名称(例如”Test”)

现在的情况明显是都不满足上面的情形,后来发现是spring的jar包版本不一致引起的:因为Lo引入的spring是4.3.9,而本项目中activiti-rest引入的是4.1.5版本

 

 

所以注释掉依赖后进行Junit测试。启动成功

 

代码交流 2021